This project is read-only.

Updatepanel troubles

Feb 8, 2008 at 2:24 PM
i have this simple code:

<asp:UpdatePanel runat="server" RenderMode="Block" UpdateMode="Conditional" ID="upn_mappa">
<ContentTemplate>
<artem:GoogleMap ID="GoogleMap1" runat="server" Width="400px" Height="400px" Key="ABQIAAAAojJioor-0DqvjrLmqzbsCBSHfJdwwxpIi7yvLxS62UleXEFBTZDT_q2dweY6mh547lELAmifIhVg"
Zoom="14" EnableGoogleBar="false" ShowMapTypeControl="false" ZoomPanType="Small">
</artem:GoogleMap>
<asp:Label runat="server" ID="error"></asp:Label>
<asp:Button runat="server" ID="btn_test" />
</ContentTemplate>
</asp:UpdatePanel>

when i click the button the map disappear!
can you help me?

2)
in page_load avent:

Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load

GoogleMap1.Address = "roma italia"
error.Text = GoogleMap1.Latitude

End Sub

the label error contains 0
it contains 0 after a postback too..

pls help me :)

any example code for us?

thank you

regards

Emiliano
Feb 8, 2008 at 6:04 PM
Hi,
I have tested code provided by you and it works for me, but I had to change the Key.
Is your Key a proper one, because ones I have fo my domains are little bit longer (actually your Key has 2 characters less than mine).
So, my suggestion is to check your Key and even go and re-issue it.

Regards,
Velio
Feb 8, 2008 at 9:34 PM
i can see the map the first time..
the map disappear only after a postback.
i've downloaded the last release version, not the sources..
is it right?

thank you for your help!

Feb 8, 2008 at 10:45 PM
i've published a test page with the code above.

http://prenotable.temporaneo.net/test.aspx

pls look at this link

after page load, i have the map active but no latitude in my label.
if i push the button to rise a postback, now i can catch the latitude but the map disappear.
any suggestion?

the code is very simple..

thank you!

regards

Emiliano
Feb 9, 2008 at 11:34 AM
Hi,
I took a look at your test page. I see the problem.
This weekend I'm going to work on improving GoogleMap control and especially the javascripts on loading maps, markers and geolocations.
I beleave after those improvements to fix such a kind of problems as you experience.
I'm going to add a support for client (javascript) callback function on loading geolocations and that way to provide ability to get Lat/Lng even before postback to server.

Regards,
Velio
Feb 9, 2008 at 1:43 PM
hi!
thank you very much!
i think you could do a great work to imrove this cotrol.
i'll be glad to make yu a donation for your work, if it's possible (paypal?)
you are solving a big trouble for me.. and i have no much time to work on my own control..
tank you again!
i can only make some tests to help you to to improve yours :)
i add a new post with other interesting features to add;)

have a nice day!

Emiiano
Feb 10, 2008 at 7:49 PM
Please, get latest release 2.7 and check out if everything is working now.
PS: Project donation page is now available here and donate link added under Project Links on the project index page.
Regards,
Velio