This project is read-only.

Geocode from address not working?

Jan 1, 2010 at 5:27 AM

I'm attempting to plug an address in along with the zipcode and then generate a marker. It works fine on my development machine, but when I upload it to the web server for testing it always shows the same location on some river in South Carolina, no matter what address is plugged in?

GoogleMarker marker = new GoogleMarker();
            marker.Address = p.address1 + p.zipcode;
            GoogleMap1.Address = marker.Address;
            GoogleMap1.Markers.Add(marker);
            GoogleMap1.DefaultMapView = GoogleMapView.Satellite;
            marker.Clickable = false;

 

Coming from a Property object, but it works fine on dev.

 

Ideas?

Jan 8, 2010 at 4:55 AM

Same problem here.  Address feature doesn't seem to work.

Jan 8, 2010 at 5:09 AM

Actually it does work fine.

The error was mine, my DBML file was pointing to the wrong DB and not pulling back the proper data.

Jan 8, 2010 at 4:16 PM

I'm setting the address property like this:

 

String address = "1419 West Monroe Ave Lowell, AR 72745"

GoogleMarker marker = new GoogleMarker(address);

 

Does that look right?

 

Jan 8, 2010 at 4:19 PM
Edited Jan 8, 2010 at 4:20 PM

Actually, you don't need the city/state to make it work.

Just pass "1419 West Monroe Ave 72745"


That should take care of it. And if not just follow what I have above for the code.

 

Jan 8, 2010 at 4:53 PM

Awesome.  I'll check it out and let you know.  Thanks for the tip.

Jan 8, 2010 at 5:48 PM

Yeah - still gettin' nothing. :-(

Jan 8, 2010 at 5:50 PM

GoogleMarker marker = new GoogleMarker();
            marker.Address = "1419 West Monroe Ave 72745";
            GoogleMap1.Address = marker.Address;
            GoogleMap1.Markers.Add(marker);

That doesn't work?

Jan 8, 2010 at 7:50 PM

Nope.  Brings up a blank map - no map even loads.  No javascript errors...nothing.

 

Jan 8, 2010 at 7:51 PM

However, if I do the same thing with long and lat, it works.

Jan 8, 2010 at 8:52 PM

I also downloaded the latest source code - it doesn't work there either.