This project is read-only.

GoogleMap Control 5.0 - InfoWindow not working

Nov 10, 2010 at 10:06 PM

Hello,

I'm trying to do a very simple example of the InfoWindow and it's not working. I am trying both on an externally hosted site and localhost. The InfoContent Page in the Samples does not appear to be working either. Any thoughts? Here is my code....

<%@ Page Language="VB" AutoEventWireup="false" CodeFile="InfoWindow.aspx.vb" Inherits="_test_InfoWindow" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
        <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>
         <artem:GoogleMap ID="GoogleMap1" runat="server" Width="634px" Height="600px" Zoom="6" Latitude="42.1229" Longitude="24.7879"  EnableScrollWheelZoom="true">
            <Markers>
                <artem:GoogleMarker Address="Plovdiv Bulgaria" Text="Please Help Me Work!!!!"></artem:GoogleMarker>
            </Markers>
        </artem:GoogleMap>
    </div>
    </form>
</body>
</html>

I'm not getting any Toolkit errors or anything. Also, when is a reference to ScriptManager actually required? I notice the map works without it. Thanks!

Nov 17, 2010 at 10:22 AM

I just upgraded from 4.1 to 5.0 and I'm also having the same problem - I click the marker icon on the map and nothing happens.  No InfoWindow is appearing at all but also no errors.

Nov 17, 2010 at 11:01 AM

Weird - I can get the InfoWindow to show if I explicitly set the OpenInfoBehaviour:

marker.OpenInfoBehaviour = OpenInfoBehaviour.MouseOver;

...but then the InfoWindow doesn't disappear when you click on another Marker, or click away from the InfoWindow. 

 

Feb 19, 2011 at 7:20 PM

Did you ever find a workaround? I've had the same problem since 5.0. Judging from the source code, it is probably an issue with .Net 4.0 and his control.